tagDiv composer doesn't save (doesn't save at all)

Posted in: ionMag
Post count: 6

Hi there,

I have an issue with the tagdiv Composer for the pages. When I have made some changes and click on the save icon, it takes forever to save the changes. Basically, the changes are never saved. How can I solve this issue?

The theme is working fine for the rest.

Thank you,

Post count: 6

Hello, it displayed this message:

Errors happened during tdcIframeData.init() -> bindViewsModelsWrappers()!

What must I do?

Help!

Thank you

Post count: 6

Hi tagDiv-heroes,

I found the problem. It basically has to do with the qTranslate plugin. In a previous question Alin already mentioned the Ionmag theme wasn’t tested with a multiple language plugin.

The tagDiv composer wasn’t able to process/save the changes after I installed the qTranslate plugin.
Which is understandable as the tagDiv composer is designed to process changes in a single language context.

So everytime I needed to change something on the frontend/pages I deactivated the plugin for the time being, made the changes in the Composer and the tagDiv composer was able to process the changes/thus saving successfully and directly.

After saving I activated the plugin again, and the requested changes are automatically cloned to the English(or any other language) frontpage.

Thought this might be useful for others as well, who plan, or are working with multiple languages.

Regards,

Jenny

http://www.thesmartpage.nl/now/

Post count: 14

I already have pages that are made with TagDiv
If I deactivate TagDiv, and then I activate it again – the existing settings will not be lost?

Simion C.
Post count: 383

Hi,

@Igor The pages are saved, they will not be lost in case you deactivate the composer. Regarding the error from the other topic try the suggestion mentioned there. Also check the theme system status
https://www.wpion.com/members/system-status/
Ask your hosting provider to increase the allocated resources if needed.

Thanks

Post count: 14

thanks for the answer
Tried to deactivate and reactivate. This option did not help. Problem still exists.
Status status is OK. Resources are enough. On all other pages of my site the plugin works. Only on the “store” page from Woocommerce TagDiv gives an error.

Simion C.
Post count: 383

@Igor replied in your other topic.

Post count: 2

Hello,
I`m new into IonMag as well as WP.
I got the same problem as this question as the tagDiv is not saving.
In debug mode i got:
*****
[05-Feb-2018 20:40:42 UTC] PHP Notice: Trying to get property of non-object in /home/someline/public/wp-includes/post.php on line 1649
[05-Feb-2018 20:40:42 UTC] PHP Notice: Trying to get property of non-object in /home/someline/public/wp-includes/post.php on line 1649
[05-Feb-2018 20:40:42 UTC] PHP Notice: Trying to get property of non-object in /home/someline/public/wp-admin/edit-form-advanced.php on line 274
[05-Feb-2018 20:40:42 UTC] PHP Notice: Trying to get property of non-object in /home/someline/public/wp-admin/edit-form-advanced.php on line 274
****
Some ide of whats wrong?
I hope somone can helpe me with this!

Simion C.
Post count: 383

Hi,

@littmeg Those would be notices, please set debugging to false unless you intentionally have it activated
https://www.wpion.com/members/system-status/
By default it is set to false. The notices should disappear after doing this.

Thanks

Post count: 2

Hello Simion,

That was not the question, that was just the only thing i got when i set debug on!
The problem is that i can`t get TagDiv to save at all, and i have no clue on why!
The saving wheel is spinning!

I hope you have some idea!

Best regards

Simion C.
Post count: 383

Hi,

Usually this issue is caused by insufficient resources, make sure all the parameters are according to the guide provided above.

Also check the PHP version used by the server, use versions up to 7.1, higher versions may cause issue.

After everything is set properly check again, test the composer on a new page. If there is still a problem check in the browser inspector console if there are any errors while using the composer
https://www.screencast.com/t/9G5E6KZQDqV
Let us know the results.

Thanks

Viewing 11 posts - 1 through 11 (of 11 total)
The forum ‘ionMag’ is closed to new topics and replies.