Errors happened during tdcIframeData.init() -> bindViewsModelsWrappers()!

Posted in: ionMag
Post count: 18

Encountered this error while trying to edit my homepage I created yesterday. Now, even accessing revisions from atleast 15 hours prior to the last save still shows the same error.

Any reason/possible cause on why this error shows up?

Thanks!

Catalin L.
Post count: 60

Hello nivrinaj,

Please try to make a new clean install from scratch via FTP way like this -> https://www.wpion.com/members/theme-installation/ because this is the surest method in this regard. Also, if you are using some untested plugins, you should disable all of them, leave just Visual Composer to active, clear all your caches, purge CDN files if you are using the CDN system and check the results. Until now, we do not have received any bad reports in this regard and I suspect this issue happened due to your unproperly theme installing or conflicts.

Hope this helps and let us know how it goes!

Thanks for your understanding!

Post count: 2

Hello πŸ™‚

I’ve been getting the following error when I try to use tagdiv composer:

Errors happened during tdcIFrameData.TdcLiveView -> customRender!

I’ve checked my system status, and all is green except for the cache – because I have no caching turned on.

I have absolutely no plugins installed except for the ionmag/tagdiv plugins.

The site does not use https. In fact, I added this site to get around what I thought was an https problem – so this site has nothing but the theme with the default demo installed on it.

I hope that this can be resolved. I love your theme so far, and am planning on purchasing your theme in September.

Simion C.
Post count: 383

Hi,

Try to deactivate an delete the tagDiv composer plugin, and then install it again from the theme package. Create a new page and try to edit it with the composer to see if the error is still displayed.
The composer is fully tested with the theme and should work properly. Usually other plugins are causing conflicts, but that is not the case here if you do not have any.
You could try as a last resort a theme reinstall by FTP, and check to see if this has any effect
https://www.wpion.com/members/theme-installation/

Thanks

Post count: 86

Also check your php version is at least 5.4, ideally 5.6 or 7.0x — anything older than 5.6 is going to give you funky gremlin errors with WP.

We solved all the super weird “nobody else having that problem” stuff moving to 5.6 … seriously.

Post count: 14

I already have pages that are made with TagDiv
If I now re-install the theme – the existing settings will not be lost?
If I deactivate TagDiv, and then I activate it again – the existing settings will not be lost?

  • This reply was modified 6 months by  Igor.
Simion C.
Post count: 383

Hi,

@Igor If you are having that error please check this. There is a setting in the Yoast SEO plugin which has been identified to cause this issue
– https://www.screencast.com/t/4Enm9q0r
Check this setting and disable it, then see if the issue is solved. Let us know if there is still a problem.

Thanks

Post count: 14

Hi, Simion
thanks for the answer
function is disabled. I tried to turn it on and off again. This option did not help. Problem still exists.

Simion C.
Post count: 383

Hi,

I see in another topic that this happens only while editing the woocommerce shop page. That page cannot be edited with the composer. It will show content depending on your settings
https://www.screencast.com/t/theUmlO5
You can use woocommerce shortcodes to display products on any page you want
https://docs.woocommerce.com/document/woocommerce-shortcodes/
These shortcodes can be entered on pages using a text element for example, with the tagDiv composer
– https://www.screencast.com/t/iejAlYOMKJOL
– https://www.screencast.com/t/Zy8mNjZ1

Thanks

Post count: 14

Thank you very much
Excellent and complete answer
You helped me a lot

Post count: 2

Hi, I have this same problem. I’ve try everything you recommend but i still haven’t resolved anything. I create a different page but it don’t let me save it. Could you please help me with this? I’ll apprecciate a lot. Thanks

Simion C.
Post count: 383

Hi,

@dekorastyleblog Usually issues with the composer (like not opening or unable to save pages) are caused by insufficient resources allocated by the hosting provider.

Please check the theme system status section, ask your hosting provider to increase the parameter values according to this guide
https://www.wpion.com/members/system-status/
Then test to see if the issues are solved. Let us know otherwise.

Thanks

Post count: 2

Hi Simion,

I did that, my memory limit was modify to

; Resource Limits ;
;;;;;;;;;;;;;;;;;;;
max_execution_time = 60
max_input_time = 60
memory_limit = 256M

But the problem persist πŸ™

Simion C.
Post count: 383

Then something else is responsible for the issue. Please check if the js files are concatenated (they should be by default)
– https://codex.wordpress.org/Editing_wp-config.php#Disable_Javascript_Concatenation
– https://www.screencast.com/t/VSkEyIYxIg
Check in the wp-config for concatenation related code. This could cause issues to tagDiv composer functionality.
Try to add this line of code in your wp-config.php file and see if it works
https://www.screencast.com/t/ndL6XZKkbX0

define ( 'CONCATENATE_SCRIPTS', true );

If it still doesn’t work, also ask your host maybe there is an option on your server which disable js concatenation or maybe they can provide another solution.
Let us know the results after you try this suggestion.

Thanks

Viewing 14 posts - 1 through 14 (of 14 total)
The forum ‘ionMag’ is closed to new topics and replies.